University of Southern CaliforniaUSC
USC ICT TwitterUSC ICT FacebookUSC ICT YouTube

Could not load scan data error | Fast Avatar Capture | Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register sp_MemberList Members

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Could not load scan data error
October 17, 2016
2:38 am
Avatar
hsn
Guest
Guests

First off, thanks for releasing such a great bit of software.

I'm having some trouble getting it to work correctly, though. Here's the output: 

Fast Avatar Capture v1.0 (prerelease)
Contributors: Evan Suma, Ruizhe Wang, Ari Shapiro, and Andrew Feng
Copyright (c) 2015, University of Southern California
Attempting to initialize Kinect sensor...
Sensor initialized successfully.
Please face the camera. Scanning will start in a few seconds.
Beginning keyframe 1 of 4.
Begin accumulating frames at angle -22
Begin accumulating frames at angle -1
Begin accumulating frames at angle 23
Please turn to the left.  Next keyframe will begin in 3 seconds.
Beginning keyframe 2 of 4.
Begin accumulating frames at angle -22
Begin accumulating frames at angle 0
Begin accumulating frames at angle 21
Please turn to the left.  Next keyframe will begin in 3 seconds.
Beginning keyframe 3 of 4.
Begin accumulating frames at angle -23
Begin accumulating frames at angle 0
Begin accumulating frames at angle 21
Please turn to the left.  Next keyframe will begin in 3 seconds.
Beginning keyframe 4 of 4.
Begin accumulating frames at angle -22
Begin accumulating frames at angle 0
Begin accumulating frames at angle 21
Reconstructing super resolution scans...
Applying color correction...
Saving scan data... done.
Initializing alignment...
Alignment complete.
Reconstructing point cloud...
Error: could not load scan data!
Reconstructing mesh...
Reducing mesh...
Applying textures...
Reconstruction complete.

Any suggestions?

October 17, 2016
10:54 am
Avatar
Admin
Forum Posts: 983
Member Since:
December 1, 2011
sp_UserOfflineSmall Offline

Reply from Evan Suma:

 

That means the alignment phase did not complete properly.  (It runs in the separate Matlab runtime exe so the only error you get in the Fast Avatar Capture program is when it can’t load the scan data for the reconstruction phase.)

 

This could happen for a couple reasons:

- Matlab runtime not installed, so the alignment program doesn’t run

- The scan data was bad, so the alignment program ran but didn’t complete

 

Tough to say specifically without seeing the scan data or output from the Matlab window.

 

- Evan

October 18, 2016
4:21 am
Avatar
hsn
Guest
Guests

I do have the matlab runtime installed. This error is happening on all scans. I've tried different subjects with different lighting conditions but still the same problem.

November 11, 2016
7:04 am
Avatar
Eduard
Guest
Guests

I am facing the same problems. I am sure MATLAB Runtime is is installed properly.

And when viewing the capture raw data, everything looks great.

But somehow always Error: could not load scan data! right after Reconstructing point cloud...

What to do?

 

Thanks

December 7, 2016
3:13 am
Avatar
Member
Members
Forum Posts: 3
Member Since:
November 14, 2016
sp_UserOfflineSmall Offline

Hello guys!

For me it is working now! What I did is uninstall FastCatureAvatar and MATLAB Runtime, then reinstall both and do NOT change any installation path...

 

Edit: Typos

Forum Timezone: America/Los_Angeles

Top Posters:

jwwalker: 80

jyambao: 52

rbaral: 47

adiaz: 30

WargnierP: 29

lucky7456969: 28

mbarros: 28

avida.matt: 26

JonathanW: 24

laguerre: 23

Member Stats:

Guest Posters: 67

Members: 99543

Moderators: 3

Admins: 4

Forum Stats:

Groups: 1

Forums: 5

Topics: 458

Posts: 2401