University of Southern CaliforniaUSC
USC ICT TwitterUSC ICT FacebookUSC ICT YouTube

Compiling Python 2.6.5 for IOS 7.1 issues | General SmartBody Discussion | Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Compiling Python 2.6.5 for IOS 7.1 issues
September 2, 2014
11:10 pm
Avatar
New Member
Members
Forum Posts: 1
Member Since:
September 2, 2014
sp_UserOfflineSmall Offline

Hello ,

The build script for Python 2.6.5 for IOS hasn't been updated to reflect the changes from Xcode 5 and the replacement of gcc completely with clang. I updated as much as I could the script but still I am failing to compile it. Is there any workaround for the moment as I am trying to build all Smarbody's dependencies for IOS 7.1 .

Edit: I was just able to compile Python-2.7.5 is it fully compatible with this svn build for Smartbody : Revision: 5821 ?

Thanks in advance,

Alex

September 7, 2014
1:30 am
Avatar
Admin
Forum Posts: 983
Member Since:
December 1, 2011
sp_UserOfflineSmall Offline

Both 2.7 and 2.6 versions of Python should be compatible with SmartBody; it's not using any features specific to those versions.

Ari