University of Southern CaliforniaUSC
USC ICT TwitterUSC ICT FacebookUSC ICT YouTube

how to make _deformBuf change? | General SmartBody Discussion | Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
how to make _deformBuf change?
November 16, 2015
3:34 am
Avatar
Member
Members
Forum Posts: 28
Member Since:
November 5, 2015
sp_UserOfflineSmall Offline

Hello Ari,

When I directly render the static mesh, it is okay.

Now want to move on to dynamic mesh, I don't want blending for the moment just for step by step approach.

So when I get the DeformableMeshInstance pointer, I will take the _deformBuf array from it.

But the mesh instance is not updated (actually I have updated the simulation manager, as well as the character itself),

the _deformBuf always contains 0,0,0!

Other containers contains the right values, such as normals, texture coordinates etc

I wonder also why the sr_gl_render_funcs::renderDeformableMesh never needs an index buffer, is it a nature of opengl?

So thanks

Jack

November 16, 2015
8:49 am
Avatar
Member
Members
Forum Posts: 28
Member Since:
November 5, 2015
sp_UserOfflineSmall Offline

Hello Ari,

Back in here this afternoon.

I've got the _deformBuf to contain some values now.

But when I set the DeformableMesh the "ChrBrad.sk" and set this deformable mesh to the character's instance.

When I updateFast it, the UpdateTransformBuffer can't find the joints in the _jointMap so that the mesh stays in

the static pose.

How do I fix this?

Thanks

Jack

November 17, 2015
8:38 am
Avatar
Member
Members
Forum Posts: 28
Member Since:
November 5, 2015
sp_UserOfflineSmall Offline

Hello Ari,

finally got it animating... but

the scale of the mesh (ChrBrad.fbx) seems not to match the skeleton (ChrBrad.sk)

The mesh has a scale of a hundred meter, and the skeleton just got about 1 meter.

When I match the skeleton to the mesh, the mesh is squashed down and becomes a little dwarf.

 

Update1:

Okay, got it resolved, I notice the fbx file has the bone set already built-in... got it working thanks

Thanks

Jack

Forum Timezone: America/Los_Angeles

Most Users Ever Online: 733

Currently Online: mondayneedle1, huberdavidsen3, casey29english, andersen19eaton, kristensen00leblanc, bager59mayo, eric506784, t9rrzpi307, g2pvwfg490
110 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

jwwalker: 80

jyambao: 51

rbaral: 47

adiaz: 30

WargnierP: 29

lucky7456969: 28

mbarros: 28

avida.matt: 26

JonathanW: 24

laguerre: 23

Member Stats:

Guest Posters: 65

Members: 52505

Moderators: 3

Admins: 4

Forum Stats:

Groups: 1

Forums: 5

Topics: 427

Posts: 2343