University of Southern CaliforniaUSC
USC ICT TwitterUSC ICT FacebookUSC ICT YouTube

Installation error | General SmartBody Discussion | Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Installation error
April 27, 2015
6:42 pm
Avatar
Member
Members
Forum Posts: 30
Member Since:
April 27, 2015
sp_UserOfflineSmall Offline

Hello. I've been trying to install SmartSim in Ubuntu 14.04 and I get the following error

#error This file was generated by an older version of protoc which is
#error incompatible with your Protocol Buffer headers.  Please
#error regenerate this file with a newer version of protoc.
#endif

In a topic of this forum a user solves this problem downgrading protobuf, but I cannot perform the action. Also, I don't find it the best option. How could I solve this issue? Thanks

April 27, 2015
7:13 pm
Avatar
Admin
Forum Posts: 980
Member Since:
December 1, 2011
sp_UserOfflineSmall Offline

We use the Google protocol buffers as a means to serialize data to the filesystem in a way that can be read quickly. There are three such files (which have the .proto extension located in the src/protocols/ folder). Those files are processed by the 'protoc' program, which in turn generates C++ files. So I think this can be fixed by running protoc against those files again using your version of the protocol buffers. Try this:

 

SMARTBODYPROTOCOLSPATH=/path/to/smartbody/src/protocols

protoc -I=$SMARTBODYPROTOCOLSPATH --cpp_out=$SMARTBODYPROTOCOLSPATH sbmesh.proto

protoc -I=$SMARTBODYPROTOCOLSPATH --cpp_out=$SMARTBODYPROTOCOLSPATH sbmotion.proto

protoc -I=$SMARTBODYPROTOCOLSPATH --cpp_out=$SMARTBODYPROTOCOLSPATH sbutilities.proto

 

Does that fix your problem?

 

Ari

April 28, 2015
4:21 pm
Avatar
Member
Members
Forum Posts: 30
Member Since:
April 27, 2015
sp_UserOfflineSmall Offline

Thank you! It solved the issue and the installation could finish succesfully.

May 11, 2015
2:23 pm
Avatar
New Member
Members
Forum Posts: 1
Member Since:
May 11, 2015
sp_UserOfflineSmall Offline

Thank you , I was having the same problem

Forum Timezone: America/Los_Angeles

Most Users Ever Online: 733

Currently Online: mondayneedle1, juhlvalenzuela2, lanp4anase, worriedutopia9579, DixieDelgado, lyinglegacy8966, eric506784
89 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

jwwalker: 80

jyambao: 51

rbaral: 47

adiaz: 30

WargnierP: 29

lucky7456969: 28

mbarros: 28

avida.matt: 26

JonathanW: 24

laguerre: 23

Member Stats:

Guest Posters: 65

Members: 52460

Moderators: 3

Admins: 4

Forum Stats:

Groups: 1

Forums: 5

Topics: 427

Posts: 2343