University of Southern CaliforniaUSC
USC ICT TwitterUSC ICT FacebookUSC ICT YouTube

r6300 build - runtime crash | General SmartBody Discussion | Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
r6300 build - runtime crash
December 3, 2015
10:02 am
Avatar
Member
Members
Forum Posts: 9
Member Since:
November 28, 2015
sp_UserOfflineSmall Offline

I updated to the latest revision and build in vs2010,
just want to use the autorigger from SB to do some experiments.

(the separate autorigging/reshape tool seems not to be in open source)

while the bins from download are working (except of missing finger links in skeleton) the new compiled bin of sbguid won't.

I got a crash in sbguid by selecting 'Window - Retarget Viewer - Apply Autorig' 

December 3, 2015
6:26 pm
Avatar
Admin
Forum Posts: 983
Member Since:
December 1, 2011
sp_UserOfflineSmall Offline

Did you download and run the sdk or build from the source code repository?

December 3, 2015
6:59 pm
Avatar
Member
Members
Forum Posts: 9
Member Since:
November 28, 2015
sp_UserOfflineSmall Offline

i build from repository to get latest revision (sdk download wont compile)

December 3, 2015
7:57 pm
Avatar
Admin
Forum Posts: 983
Member Since:
December 1, 2011
sp_UserOfflineSmall Offline

Can you please post the compile errors that you are getting? 

Ari

December 3, 2015
8:40 pm
Avatar
Member
Members
Forum Posts: 9
Member Since:
November 28, 2015
sp_UserOfflineSmall Offline

no - there is no compile error - as i mentioned in the post header - its a runtime error of the compiled binary (sbguid.exe),
compiled from repository.
the same problem is mentioned in this thread:
http://smartbody.ict.usc.edu/f.....ay-correct
I saw you answered by suggesting to download the autorigging tool.
But that wont let us the freedom of adding own features to the autorigger (which is closed source in the tool)
I would like to experiment on missing skeleton parts (fingers) in the source code.
So it would be helpful to get a working revision of the repository sources to use it as a base for further development...

thx - fran

December 3, 2015
8:41 pm
Avatar
Admin
Forum Posts: 983
Member Since:
December 1, 2011
sp_UserOfflineSmall Offline

Can you send me the model that you are using so that we can fix the problem?  shapiro@ict.usc.edu

 

Ari

December 3, 2015
9:11 pm
Avatar
Member
Members
Forum Posts: 9
Member Since:
November 28, 2015
sp_UserOfflineSmall Offline

i used your own provided models from SmartBody

e.g. ChrBrad

but any model will reproduce the bug

here is last console output after pressing  'apply Autorig' button:

Generating Deformable Model Name = SB_ChrBrad.obj, size of pos buffer = 39743, size of color buffer = 39743
Found 10 behavior sets under path ../data/behaviorsets
Start Build Auto Rigging
OBJ path: testVolCubic.obj

next - the application is no more responding and crashes

as i mentioned the other thread by longpo1988 reporting exactly the same issue

December 3, 2015
10:08 pm
Avatar
Admin
Forum Posts: 983
Member Since:
December 1, 2011
sp_UserOfflineSmall Offline

Ok, we checked in a fix into revision 6302.

Please update and try again.

 

Ari

December 3, 2015
11:07 pm
Avatar
Member
Members
Forum Posts: 9
Member Since:
November 28, 2015
sp_UserOfflineSmall Offline

updated - compiler error:

SBAssetManager.cpp
..\SmartBody\src\sb\SBAssetManager.cpp(2205): error C2039: 'export_obj' : is not a member of 'SrModel'
C:\Users
oot\Documents\Visual Studio 2010\Projects\SmartBody_6298\core\smartbody\SmartBody\src\sr/sr_model.h(55) : see declaration of 'SrModel'

December 4, 2015
12:21 am
Avatar
Admin
Forum Posts: 983
Member Since:
December 1, 2011
sp_UserOfflineSmall Offline

Ok, just fixed. Please update and try again.

December 4, 2015
1:20 pm
Avatar
Member
Members
Forum Posts: 9
Member Since:
November 28, 2015
sp_UserOfflineSmall Offline

last r6303 lets the compiler run be successful.

but the problem persists in the same way as before:

- start sbguid.exe

- load .ply (or .obj) model by drag/drop (i use the model that i sent you by mail)

- create pawn from model
 output console:Generating Deformable Model Name = ChrBrad_test.ply, size of pos buffer = 39391, size of color buffer = 39391
Found 10 behavior sets under path ../data/behaviorsets

- window - retargetviewer
 shows the shaded model in preview window rigging/tetargeting

- press button 'Apply Autorig'
 small voxelWindow appears with white bg
 console:Start Build Auto Rigging

- after 3min voxelWindow disappears, preview windows content renders white
 console:OBJ path:           testVolCubic.obj

- application no more responding

December 5, 2015
1:10 am
Avatar
Admin
Forum Posts: 983
Member Since:
December 1, 2011
sp_UserOfflineSmall Offline

It does seem to be working, but unfortunately, using the STL in debug mode is very slow (I'm running it now, it's almost done after 1/2 hour...)

First, it looks like the model you sent me is very large. I recommend reducing the size of it before running the autorigger:

scene.loadAssetsFromPath("/path/to/my/file/ChrBrad.ply")

p = scene.createPawn("mycharacter")

p.setVec3Attribute("meshScale", .0001, .0001, .0001)

p.setStringAttribute("mesh", "ChrBrad.ply")

 

Then you can run Window->Retarget Viewer

 

Ari

December 5, 2015
10:26 pm
Avatar
Member
Members
Forum Posts: 9
Member Since:
November 28, 2015
sp_UserOfflineSmall Offline

yes - you're right - the debug build seams to run in some memory leak (about 800MB peak).

i build the release and then i'm able to autorig the model in a few secs, whereas the debug build process is running ~ 2h.
this helps a lot - thx for your excellent support

a tout a l'heure - fran

Forum Timezone: America/Los_Angeles

Most Users Ever Online: 733

Currently Online: Jamesnuh, gotselyuk1987mon, koenig62ramos, krygerhagen69, coxgeorge3, doyle68bekker, ludvigsen62abbott, shortstext78, cormierhopper5
68 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

jwwalker: 80

jyambao: 52

rbaral: 47

adiaz: 30

WargnierP: 29

lucky7456969: 28

mbarros: 28

avida.matt: 26

JonathanW: 24

laguerre: 23

Member Stats:

Guest Posters: 67

Members: 100502

Moderators: 3

Admins: 4

Forum Stats:

Groups: 1

Forums: 5

Topics: 460

Posts: 2403